Mixamo model import error in AssetImporter

General discussion around Urho3D.

Mixamo model import error in AssetImporter

PostPosted by Lumak » 09 Dec 2016, 16:12

Anyone ever come across an error shown below?
Code: Select all
Could not open or parse input file <somemixamomodel.fbx>: invalid vector<T> subscript


There is a fix that I can provide forcing fbxconverter to skip processing animation on model import. I'll submit a PR if it's in demand.
Lumak
Have many posts
Have many posts
 
Posts: 425
Joined: 08 Jun 2015, 15:38

Re: Mixamo model import error in AssetImporter

PostPosted by rasteron » 09 Dec 2016, 20:02

Hey Lumak,

have you tried converting your FBX to 2013 version before converting with Assimp? You can also try exporting it with Blender.
User avatar
rasteron
Have many posts
Have many posts
 
Posts: 437
Joined: 07 Mar 2014, 07:46
Location: web

Re: Mixamo model import error in AssetImporter

PostPosted by Lumak » 10 Dec 2016, 15:17

I don't use Blender but do convert them to fbx 2013 version.

I was able to reproduce this error even when retargeting animations and discovered how to solve this problem. If you see this error just add animation key to the "Hips" joint on the 1st frame and it'll solve it. No importer code changes required.
Lumak
Have many posts
Have many posts
 
Posts: 425
Joined: 08 Jun 2015, 15:38

Re: Mixamo model import error in AssetImporter

PostPosted by rasteron » 10 Dec 2016, 21:43

Ah ok got it thanks.
User avatar
rasteron
Have many posts
Have many posts
 
Posts: 437
Joined: 07 Mar 2014, 07:46
Location: web


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 0 guests

cron